SQL Connection - Failed to connect - self signed certificate

If you run into the following error in Builder, or if you are setting up a SQL connection in management and get this error - “Failed to connect to ‘serverdetails’ - self signed certificate”

This is likely due to the SQL connection requiring a valid certificate, or being on a legacy environment that might require it. The following would be added to your SQL connection string normally - “trustservercertificate=true”

Add the following under your options in your sql connection in management.


  "options": {
    "trustServerCertificate": true

Please note that using “TrustServerCertificate=true” in your connection, skips the trust chain validation. This will allow it to connect even if the certificate can’t be verified.
Best practice is to have a valid certificate.